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Welcome to the Pyramix ADR Guide!

Introduction

Thank you!
Congratulations on your purchase. The Pyramix ADR system is an extremely powerful aid to rapid and accurate 
dialogue replacement.

Please subscribe to the User Forum at:

http://www.merging.com/forum/ 

Overview

The Merging Technologies ADR option adds and integrates dedicated functions to a Pyramix / VCube combina-
tion. These functions include:

• Automatic loading of video media files in VCube

• Multiple Characters in a single project

• Wipe and Countdown with various styles.

• Automatic Monitoring Control

• Automatic Effects Control

• Take control and Consolidation

VERY IMPORTANT!

We strongly recommend you also consult the Pyramix User Manual and the VCube User Manual for a more com-
plete understanding of all the features and functions of Pyramix and VCube.

Scope
This document covers the ADR option for Pyramix and VCube. It is intended to introduce the Merging Technolo-
gies approach to ADR and to help guide you through the learning curve. It also has detailed descriptions of all the 
commands and Tab window functions.

Familiarity with Pyramix and VCube is presumed.

Documentation and Help

ToolTips
Merging Technologies Software is equipped with ‘ToolTips’. Hovering the mouse cursor over a tool icon pops-up a 
box with the name of the function etc. A longer description is shown bottom-left of the Pyramix program window.

Documentation
All the Merging Technologies documentation is in the Adobe Acrobat pdf format. (.pdf file extension)

In order to read the documentation you will need to have Adobe Acrobat Reader V5 or later installed on your 
computer.

The Pyramix User Manual may be opened from the Pyramix Help menu. Other documentation can be found in 
the Windows Start menu in All Programs > Pyramix > Docs and All Programs > VCube > Docs. Please check for 
the most recent versions at:

 http://www.merging.com
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Support
If you cannot find an answer to a query in the documentation, please consult the on-line support at:

 http://www.merging.com

where you will find answers to F.A.Q.s (Frequently Asked Questions) and further support.

Assumptions
This ADR Guide and the other Pyramix documentation assume you are thoroughly familiar with PCs and Windows 
terms and concepts. If self installing to a new PC, please ensure the machine is working correctly before attempt-
ing to install Pyramix Virtual Studio with ADR option, VCube and Virtual Transport.

Conventions
Conventions used in Merging Technologies documents:
Names found on screens and menus are shown in bold the first time they occur and often later to highlight them. 
E.g. Information & Settings

Menu and sub-menu selections are shown like this:

View > Tracks > Show all Tracks

Which means:

Go to the View pull-down menu, mouse down to the Tracks sub-menu and choose Show all Tracks.

Where a dialog box has several Pages, Tabs are used to select the pages. Tab Page selection is shown thus:

Settings > Keyboard Shortcut Editor : Active Machine

Which means:

Go to the Settings pull down menu, choose Keyboard Shortcut Editor then click on the Active machine Tab.

The Pyramix Settings > All Settings dialog Has its own hierarchical tree structure in the left-hand pane with fold-
ers leading to pages.

Navigation
All Contents and Index entries and Cross-References e.g. Please see: Getting Started  on page 9 are Hyper-
links. Clicking on them will take you straight to the subject.
ADR Guide : Overview Page 6
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User Interface

The ADR option adds a menu and a Tab Window to the main Pyramix window.  

Keyboard Shortcuts
Of course, any or all of the menu commands can be assigned to keyboard shortcuts in Settings > Keyboard 
Shortcut Editor in the ADR tab page. 

Note: We strongly recommend you use Keyboard shortcuts and/or a hardware keypad in 
order to fully appreciate the Merging Technologies ADR experience. 

GPIs and GPOs
Any or all of the menu commands may be assigned to General Purpose Inputs (GPIs) for activation from any exter-
nal switching source in Settings > All Settings > Project > Controller Mapping (Choose the GPIO controller you 
have installed and click on Properties to open the Mapping dialog.)

Similarly, Cue and Status indicator light switching plus Beep and Countdown can be mapped to General Purpose 
Outputs (GPOs). Please see: GPO Commands  on page 31

Toolbar

All ADR Commands have Toolbar Icons and these can be added to the ADR Toolbar In Settings > All Settings > 
Application > Desktop Layout in the ADR tab page.

ADR Tab Window
The ADR Tab Window has four Tabbed pages.

Loops . 

This is the primary page of the ADR system Tab window and should remain visible throughout an ADR session for 
quick and easy access to all of its functions. It shows all the Loops and their current Status and enables the user to 
prepare an ADR session by creating Loops, erasing, sorting and assigning ID numbers to them.   Loops can be 
assigned to Scenes, Characters assigned to Loops and the Loop Type be notated. In the recording session this is 
the page where the user can also activate Loops, select previously recorded Loops as Selected Takes (final takes), 
define the Status of work in progress, and add comments.

ADR Toolbar

ADR Tab Window Loops page
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Production 

This page allows the user to enter and view Production information, add and view Characters and set up Scenes. 
Scenes are very important because they point to video files. This enables VCube to automatically load them as the 
Loops require.

Monitoring 

In this page the sophisticated monitoring and effects logic is set up.

For switching purposes each Loop is defined in three phases, PreRoll, Punch-In and PostRoll. The first section 
deals with Routing and Effects Switching for each of three possible Guide Tracks during each Loop phase. In the 
second section Monitor destinations are patched to Mixer Output Buses with one of three logic switching matrices 
applied and in the third section the switching rules are defined.

Settings
Has all the detailed settings relating to the ADR option. Please see: Settings  on page 28

ADR Tab Window Production page

ADR Tab Window Monitoring page
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Getting Started

Because of the complex interaction of several processes we strongly recommend you use one of the pre-prepared 
templates or better still the Demo Project to gain familiarity with the many features of the ADR option. Two Tem-
plates are currently supplied, more will be added later. For the purposes of this walk though we are using a 
“PyraCube”. That is Pyramix and VCube SE running on a single machine. Before doing anything else, please open 
Pyramix and VCube and check a few settings. Please see: Settings  on page 28

First ADR Project
Choose Project > New from Template to open the Select a Template browser. Double-click on the ADR folder 
and select either ADR (2 Actors 1 Mic).pmt or ADR (2 Actors 2 Mics).pmt. The two projects are identical except 
that the second has two Mics per actor and therefore stereo mixer strips and records twice as many tracks. Follow 
through the dialog boxes to create your Project in the directory of your choice.

In the following example ADR (2 Actors 1 Mic).pmt is used for simplicity.

Set Up ADR Project
Start in the ADR Tab Window, Production page and enter a Name for your production and any other details you 
wish in the Production Information section. The screenshot below shows examples of this and the rest of the 
page:  

In the Scenes section first click in the Video File column opposite the 1 / 1 Name entry to open the Select a 
Video File browser. Navigate to the video file associated with your project and click on Open. Notice that the path 
appears in the field where you clicked. If necessary enter an offset in Video TC In.

Add other information details as you wish and name your Character(s)

For our current purposes leave the Settings and Monitoring pages as they are for now with these exceptions:

1. In the Settings page, in the Loops Editing section, set Create New Loop on Change to No.

2. In the Monitoring page, in the Monitoring Buses section click in the Character column where it currently 
says Actor 1 and select a name you entered earlier in the Production page. Repeat for Actor 2 if you have two 
actors.

ADR Tab Window Production page
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Set Up the Mixer
Note: All the buses are AUXs. All five can be controlled automatically by the Bus Switch-
ing Matrices in the Monitoring page of the ADR Tab window.

The Template uses the first two physical inputs for the Mic Inputs on Mixer Strips 1 & 3 and retains your existing 
Monitor output assignments. 

Note: The Input and Monitor strips for the Active Loop Character are automatically col-
ored to match the Active Loop Character.

Load Guide Track(s)
In the Pyramix Timeline load the voice Guide Track on tracks 1&2 already labeled Guide Track. If you also have an 
M&E, load this on tracks 3&4.

Enter Loops
On the assumption you already have a list of In and Out points, you can create Loops in this manner:

1. Select New Loop In in the ADR menu. A new Loop appears in the ADR Tab Loops page.  

Note:  the In point defaults to the current Playhead Cursor position. 

2. If you wish to enter the In and Out points manually simply click in the fields and enter the numbers in the 
usual way.

3. Set the correct Character name by clicking in the Character field and selecting the name you require from the 
drop-down list.

Add the rest of your loops by repeating steps 1 - 3. Don’t worry if the ID field shows ? You can click on the ? and 
add the number manually or just select Renumber all Loops from the ADR menu when you have entered all the 
Loops.

Pyramix Mixer Window with Loop acti-
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Note: If you turn Auto Re-number on New Loop  on (Yes) in the Loops Editing Section 
of the Settings page of the ADR Tab window then you won’t need to bother with manu-
ally numbering or renumbering.

The Loops page should now look something like this: 

If there is no pre-existing list of loops then position the Playhead Cursor at the desired In point for the first Loop 
and select New Loop In. Then re-position the Cursor to the desired Out point and select Set Loop Out. Repeat the 
process for the second and subsequent Loops.

ADR Tab Window Loops page
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First ADR Session
With the Loops entered:

Set the Record Path in the usual way (Settings > All Settings > Project > General : Project Media folder section)

Click on the first Loop you wish to re-voice to select it.

Activate the Loop either by choosing Activate Loop in the ADR menu or by double-clicking the Loop in the list.

Notice that the Pyramix and VCube Playhead Cursors jump to the Loop In point and that a new Track appears in 
the Pyramix Timeline with Punch In and Out Markers set to the In and Out points. 

Choose Rehearse. The Cursor jumps back to the beginning of the PreRoll and goes into Play. Countdown is 
shown and Beeps are audible leading up to the In point. A Wipe crosses the screen to indicate the duration of the 
Loop. Play continues until the end of the PostRoll when the Transport stops.

When you are happy with the rehearsal choose Record (If you are new to this, take a tip and record all the rehears-
als as well. Sometimes they never get any better than the first rehearsal) and notice that the new Recorded Take 
appears in the Track. Use the Review command to listen to the Take you’ve just recorded. Each subsequent Record 
pass adds another Track. If an earlier Take is deemed better than the most recent it can be Selected by using the 
Select Previous and Select Next commands.

When you have a good Take Activate the next Loop and continue until finished.

Note: At the end of the recording session you can use the Consolidate Loops and Takes 
command to produce a file or files for each Character suitable for loading into a Pyramix 
Editing Project on any Pyramix Workstation or Export to other formats. I.e. the ADR 
option is not required to edit the output 

.

Pyramix ADR with three recorded Takes on Loop 5
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Pyramix, showing three recorded Takes for Loop 5. The red dot indicates that Loop 5 is active. The blue highlight 
shows that Loop 7 has been selected. Double-clicking it will select it.

Note: The Clips on tracks 5,6 and 7 are automatically colored to match the Character 
they relate to. 

Tips and Tricks

Entering Loops
For efficient manual loop entry make full use of the options in the Loops Editing section of the Settings page. 
Please see: Loops Editing  on page 21 . 

Be sure to check these options before running an ADR recording session to avoid unwanted behavior if Loops 
require editing during the session.

ADR Tab Window

Loops Page

This is the primary page of the ADR system and shows all the Loops and their current Status and enables the user 
to prepare an ADR session by creating Loops, erasing, sorting and assigning ID numbers to them.   Loops can be 
assigned to Scenes, Characters assigned to Loops and the Loop Type be notated. In the recording session this is 
the page where the user can also activate Loops, select previously recorded Loops as Selected Takes (final takes), 
define the Status of work in progress, and add comments. This Tab window should remain visible throughout an 
ADR session for quick and easy access to all of its functions.

Note: A Loop list can be sorted in several ways by simply clicking on the column head-
ings. In the example above, the list is sorted by ID number. A star * is appended to the 
column name to indicate this.

Loops Page Columns
ID Directly below ID the colored dots indicate Loop Status. Green means that 

recorded Takes exist. Red indicates the Active Loop. No dot means that the loop 
has no recorded takes and is inactive.

ID The ID column of the ADR/Loops page can be used to rapidly renumber Loops 
sorted according to another parameter, e.g. Character. When used with the 
Renumber All Loops function the ID column will be renumbered, replacing any 
pre-existing characters or number distinctions from the top of the column to the 

ADR Tab Window Loops Page
ADR Guide : Tips and Tricks Page 13



bottom. You may sort columns by ID, In, Out, Duration, Scene, Character, Type, 
Date, Status or Comments but not Takes or Selected.

In The In column shows the current Loop In position of each Loop and allows the 
user to adjust the TimeCode value of each Loop In position by first selecting the 
Loop, then clicking in its Loop In field, then entering the new TimeCode value 
using the Pyramix numeric keypad and finally validating the new TimeCode posi-
tion by pressing Enter on the numerical keypad or cancelling by pressing ESC. The 
Loop In position may also be modified by updating the Playhead Cursor position 
in the Timeline and then simply using the Set Loop In function.

Out The Out column shows the current Loop Out position of each Loop and allows the 
user to adjust the TimeCode value of each Loop Out position by first selecting the 
Loop, then clicking in its Loop Out field, then entering the new TimeCode value 
using the Pyramix numeric keypad and finally validating the new TimeCode posi-
tion by pressing Enter on the numerical keypad or cancelling by pressing ESC. The 
Loop Out position may also be modified by updating the Playhead Cursor posi-
tion in the Timeline and then simply using the Set Loop Out function.

Duration Duration shows the total time between the Loop In and the Loop Out positions 
of the current Loop. This field cannot not be modified directly and is intended for 
reference only.

Scene Scene is where the user may assign a Scene (previously created in the ADR/Pro-
duction page in the Scenes section) to a Loop. In that page each Scene is 
assigned a video file which is loaded into the VCube automatically when a Loop is 
activated. So essentially, assigning a Scene to a Loop assigns it a correctly offset 
video file for playback and recording in sync with picture.

Character Character allows the user to assign a Character (previously created on the ADR/
Production page in the Characters section) to the current Loop. When the cur-
rent loop is activated and the VCube loads the associated video file into its Time-
line it also generates countdown and Loop record wipes with the Character's name 
and individual color and embeds them into the picture output out from the VCube 
as a visual aid in timing cues.

Type The Type column contains simple text fields which enable the user to make notes 
about the type of Loop content for reference and quick sorting of the Loop list by 
type.

Date Date displays the creation date of the most recently recorded take of each Loop. 
This column's fields cannot be modified and are intended for reference and sorting 
purposes.

Takes Takes shows the number of existing Takes for each Loop. The values in this column 
are intended for reference and may not be modified or sorted.

Selected The Selected column shows the number of the currently selected Take for each 
Loop. If the user wishes to change the currently selected take of a given Loop they 
must use the Select Previous Take and the Select Next Take functions to do so. 
The values in this column are intended for reference and cannot not be modified 
or sorted.

Status The Status column contains simple text fields which enable the user to make a 
note as to the current status of a Loop for reference and quick sorting. This field is 
typically used to indicate if a Loop is for example finished, or started, or maybe 
refused or accepted. This column may be sorted for quick reference.

Comments The Comments column contains simple text fields which enable the user to make 
a note of any kind for reference and quick sorting of the Loop list.
ADR Guide : ADR Tab Window Page 14



Production Page

Production Information
This section of the Production page is for users to add text information identifying the project and any other 
information that may be felt necessary.

Name Text Field for the Project Title

ID Text Field for a Production identification code.

Producer Text field for name of Producer.

Editor Text Field for name of Editor.

Notes Text Field for adding any notes relating to the Project

Scenes
This section of the Production page enables the user to define the scenes to be dubbed in the current Project. 
Once a new scene has been created it can be assigned a video file for playback by the VCube. The video file may be 
offset in the Video TC column. Once a video file is properly referenced to a Scene the activation of a Loop associ-
ated with that Scene automatically loads the video file into the VCube Timeline. If a Loop is activated that calls a 
different Scene and there is a different video file for that Scene the VCube automatically replaces the old video file 
with the new one. In this manner no Compositions (VCube Projects) need to be manually loaded into the VCube 
when changing scenes in the ADR/Loops page in the Pyramix, the whole process is automatic and hassle free.

Name Name enables new Scenes to be created and assigned a suitable name in accor-
dance with edit and script indications. The Scene Name is automatically included 
in the name of each recorded Take for reference when editing takes into final dia-
logue predub Projects.

ID ID allows for a production code to be assigned to a scene.

In In enables the user to mark the beginning of the scene in TimeCode format for ref-
erence.

Out Out enables the user to mark the end of the scene in TimeCode format for refer-
ence.

Reel Reel allows for the user to mark the Reel Number containing the scene if the 
project is divided into cinema reels for reference.

ADR Tab Window Production Page
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Video File Clicking in the Video File box of a given scene opens a Select a Video File 
browser box which enables the user to choose the appropriate video file for use 
with the current scene. This information is passed to VCube through the Virtual 
Transport communication and enables VCube to find the correct file and open it 
on a video track automatically when a Loop in this Scene is activated.

Video TC In Clicking in the Video TC In box of a given scene allows the user to type in an offset 
if required to synchronize the associated video file correctly with the ADR project. 
This field is in the TimeCode format of the current Pyramix ADR project and sets 
the first frame of video to the position entered in this field. Note: If the video file 
contains a burnt in TimeCode in the first frame use this TimeCode to set the Video 
TC In point of the current scene.

Picture Version This column contains text fields enabling the user to add an appropriate reference. 

Characters
This section of the Production page enables the user to create the Characters required for the current produc-
tion including actors' names. It also allows for color coding each Character for easy identification and loop sorting. 
This is also where each Character is assigned to their respective microphone input Strips and audio monitor out-
put Strips.

Name New Characters are created here according to the name in the production’s script. 
This name is also automatically included in the name of each new take recorded 
for reference when editing Takes into final dialogue predub projects.

ID Enables the user to assign an individual production code to each character for 
script referencing.

Actor Name Enables the user to enter the actors' stage names for reference.

Color Click in the field to pop-up a color-picker and assign an individual color to the 
Character for fast visual reference in the Loop page, and on the Track Groups and 
also on the Mixer Input Strips.

Record Strip This is where the user assigns each Character’s microphone to a specific Input 
Strip on the Mixer. By associating each Character's microphone to a specific Input 
Strip on the mixer the ADR Loop section is able to assign the proper Input Strip to 
the Record Track that is automatically created when a Character's Loop is activated 
and after each new loop Record Pass. All the other Tracks (Takes) of the current 
Character will be routed to the assigned Play Strip automatically for review 
passes.

Play Strip This is where the user assigns each Character's Take Playback Tracks to a specific 
Input Strip on the mixer. All Tracks in a character's group except the Record Strip 
will be sent to the ADR Monitor Section through this Play Strip. The Play Strips 
are also used to send the audio Countdown Beeps for each individual actor to 
their headphone circuit individually through the ADR Monitoring section. This 
way actors only hear their own audio Beeps and not those of the other actors so 
they can remain focused on their own entry timing.
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Monitoring Page

Note: Unless one of the Monitoring busses is selected (highlighted) nothing will be dis-
played in the Selected Monitoring Bus Switching Matrix section.

Guides Monitoring & FX Processing
This section of the Monitoring page enables the user to define two things concerning playback Guide Tracks. 

1. Associate each of the three Guide Track Monitor Logic Matrices to specific Mixer Input Strips for automatic 
Auxiliary Bus switching.

2. Choose at which stages (PreRoll, Loop and PostRoll) of Recording, Rehearsing, or Reviewing, plug-in effects 
will be automatically switched ON and OFF in each of the three Guide Track Monitor Logic matrices. An exam-
ple of three Guide tracks might be (1) Dialog pre dubs (2) Music&Effects (3) Optional/Crowds etc. each of 
which may benefit from a different effects switching scheme.

Play Strip Here the user can assign Mixer Strips to one of the three possible Guide Track 
Monitor Logic Matrices. Once the Guide Track Monitor Logic Matrices have been 
assigned to specific Mixer Strips the following columns of Rehearse, Record, and 
Review will actively switch on and off any Plug-in effects present on that specific 
mixer strip according to the table. This function permits a Plug-in effect to be 
assigned to a specific stage of the Loop Pass. For example the user may wish to 
apply a graphical EQ to the original dialogue track to filter out the voices on the 
track but allow other sounds to pass through.

Rehearse/Record/Review 
Pre Clicking in a Pre field toggles Fx On or blank (FX Off ) to activate or de activate any 

Plug-in effects on the Guide Track Mixer Strips selected in the Play Strip column 
during the PreRoll period of a Loop Pass.

ADR Tab Window : Monitoring page
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Loop Clicking in a Loop field toggles Fx On or blank (FX Off ) to activate or de activate 
any Plug-in effects on the Guide Track Mixer Strips selected in the Play Strip col-
umn during the Punched in period of a Loop Pass.

Post Clicking in a Post field toggles Fx On or blank (FX Off ) to activate or de activate 
any Plug-in effects on the Guide Track Mixer Strips selected in the Play Strip col-
umn during the Post Roll period of a Loop Pass.

Monitoring Busses
This section defines the audio switching that will be applied to each headphone circuit and loudspeaker system 
individually. Although the switching definitions must be carefully constructed, and may seem complex at first, 
once in place and functional this feature simplifies an ADR session considerably by allowing the recording engi-
neer to focus on the dialog being recorded without being distracted by monitoring issues.

In the Monitoring Busses section the user defines the total number of Output Monitor Bus Switching Matrices 
required for the entire ADR recording session. If for example there is a stereo loudspeaker system, two actor head-
phone circuits, one headphone for the recording engineer, and an additional headphone circuit for the artistic 
director then the user will need to create five Output Monitor Bus Switching Matrices in this section. (Currently, 5 is 
also the maximum number) Each of these must then be applied to a pre-existing Mixer Aux Bus. (In the Aux Bus 
column)

There are three Base Types of pre-defined Bus Switching Rules. When the user selects a Matrix in the Monitor-
ing Buses section the Bus Switching Rules to be applied are displayed in the Selected Monitoring Bus Switching 
Matrix section. These rules may further be modified at any time to fit the particular requirements of a specific 
recording session.

Name Is where the user creates and names new Monitoring Bus Switching Matrices to 
be associated with actual Auxiliary Buses on the Mixer. The names of the Moni-
toring Buses should be thought of as the names of the actual outputs in the ADR 
recording studio to simplify their roles. For example a Bus to be used for an actor's 
headphone circuit could be named ACTOR 1, or a Bus for the studio monitor loud-
speakers could be named STUDIO. You should use whatever names you usually 
use for your monitoring equipment here so you know immediately which object 
you are addressing in the Monitoring Bus Switching Matrix section. 

Aux Bus Here, the user assigns the Monitoring Bus Switching Matrix objects created in 
the Name fields to the actual Auxiliary Output Buses on the Mixer. To simplify: The 
Monitoring Bus Switching Matrix objects follow the Switching Matrix rules. The 
Auxiliaries are the outputs of the ADR module and this is where they are assigned 
to the Switching Matrices.

Character The Character column fields contains a pull-down menu with all the Character 
names created previously in the Production page in the Character section. These 
Character Names do not affect the actual Mixer Monitoring Buses or the Switch-
ing Matrix but are included for quick reference when working with large ADR 
projects where changing monitoring equipment may become complex. For exam-
ple imagine that one actor has very specific elements in his/her headphones while 
others have a more basic headphone setup and, for some reason, that particular 
actor changes headphones and the recording engineer wishes find the special 
auxiliary quickly and simply change its outputs instead of re-doing all the actors' 
switching matrix rules. Having marked that actor's special bus enables it to be 
found quickly. 

Base Type Fields in this column contain a pull-down menu with three default Bus Switching 
Rule Sets for quick and easy switch matrix setup per monitoring bus. The three 
types try to encompass the most common switching conditions for Actors, Edi-
tors, and the main Studio Loudspeaker system. By default the Studio Base Type is 
assigned to new Monitoring Bus Matrices but the Actor and Editor Base Types 
may be chosen and further modified at any time. 

Note: Modified Base Types display a star (*) after their names to indicate custom setting 
in the switching matrix.
ADR Guide : ADR Tab Window Page 18



Selected Monitoring Bus Switching Matrix
This section allows the user to modify the Base Type sets of Switching Rules applied to sound sources before they 
are sent to Output Buses. In the Left column the three Guide Track Output circuits and the Character(s) Input 
Monitor sources are shown. These are all the different types of sound sources that may be automatically switched 
to the ADR monitoring outputs. The Rehearse, Record, and Review columns represent the three Loop modes of 
the ADR system and are further broken down into the three Loop playback/record periods; Pre, Loop, and Post. 

Note:  The Guide Track switching is either Play or blank meaning Mute. So, depending 
on the Active Loop mode and the current Loop playback/record period the Guide 
Tracks may be automatically switched ON or OFF in any combination and to any head-
phone or loudspeaker. The Character sources differ in that they may either be in Input 
or blank meaning Mute which means the microphone signal will either be Input 
through to headphones and/or loudspeakers or off. 

This section requires some experimentation with modifications to the three Base Types of Switching Rules to 
become familiar with its power and functionality but, once the user has a clear understanding of what is possible, 
this Switching Matrix is a time saving and very powerful feature of the ADR system. When the Monitoring Bus 
Switching Matrix is properly setup, the ADR recording session is considerably simplified and the recording engi-
neer's job made much easier.
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Settings Page

Settings Page Continued
As the name implies, the settings which control general behaviour can be found in this page. The Loops Editing 
settings are principally applicable when preparing an ADR session.Timings sets parameters for PreRoll and Pos-
tRoll timings in Play and Record. Countdowns sets parameters for the Number, Style, Length and appearance 

ADR Tab Window : Settings Page
ADR Guide : ADR Tab Window Page 20



of Countdown graphics. Beeps sets similar parameters for the audible Beeps that usually accompany the Count-
down graphics. Lastly, Wipes does the same for the graphics displayed during the Punched-In phase of the Loop.

Loops Editing
Auto-Sort on New Loop When this parameter is set to Yes all new loops created in the ADR/Loops page are 

placed in the Loop list according to their current sorting status. The sorting status 
is defined by the nature of the content in the column that is currently sorted in the 
ADR/loop page. A star (*) symbol indicates the currently sorted column. If, for 
example, the In column is sorted all the Loops will appear in that order from first to 
last in the Timeline. A new Loop will be created in relation to the current Playhead 
Cursor position in the Timeline and will therefore be placed in the loop list accord-
ing to its In position. When this parameter is set to No all new Loops created in the 
Loop list are placed immediately after the currently selected Loop. If the sorted 
column is numerical in nature the ID of the new loop will be the number of the last 
source loop followed by a decimal separator and a sub-number. i.e.: Loop ID 7 
makes a loop ID 7.1

Auto-Renumber on New Loop  This function overrides all distinctions entered in the ID column, replacing each 
Loop's ID with a number in ascending order from the top of the Loop list to the 
bottom each time a new Loop is created. Renumbering the ID column of each loop 
permits the quick tagging of a Loop list to then later re-sort the list by any other 
criteria and quickly compare results. Typically this is used to estimate the remain-
ing work to be done by combinations of actors according to their roles in com-
bined scenes in relation to one another and studio presence etc... When this 
parameter is set to No the creation of new Loops does not renumber the list and 
ID tags are preserved and created normally.

Create New Loop on Change  When this parameter is set to Yes all changes to the In or Out positions of the 
selected Loop automatically creates a new Loop with the same complimentary In 
or Out value, assigns the new Loop to the same Character as the selected Loop 
and re-copies the Status and Comments columns.

Auto-Sort on Change ***Not yet sorting ***

Auto-Renumber on Change  ***Not yet renumbering***

Auto-Consolidate after Record  When this function is set to Yes after a first Loop Record pass the selected Loop 
is placed on a new track under the Guide Tracks in the Timeline. Each following 
Loop Record pass updates the contents of the Consolidated Track with the latest 
Selected Take. This keeps the Consolidated Track(s) up to date at all times and 
facilitates the Review of pre-recorded Takes by always having the latest versions 
ready for Playback.

No Overlap on Consolidate   When this function is set to Yes and a Consolidate command is executed every 
new Consolidate of a Loop creates a separate Consolidate Track but only IF 
Loops for the current Character will overlap in the Timeline. This keeps adjacent 
Loops from covering each other up when Consolidated on a single Track.

Timings
Play Pre Roll This setting defines the Preroll time leading up to the Loop In position including 

the Countdown and Beep 

Note: This value should be longer than the Countdown and Beep sequence 
lengths in order to properly display and monitor them.

Play Post Roll This setting defines the Postroll time after the Loop Out position. When the ADR 
system reaches the end of the Post Roll time the system either stops or cycles 
back to the Pre Roll position and continues Playback if in one of the three Cycle 
modes.

Punch In Pre Roll This setting defines the offset of the actual Record On command in relation to the 
Loop In position. This enables the user to record before the actual first dialogue to 
anticipate breath sounds or dialogue that is prematurely spoken in relation to the 
actual take. If an actor tends to rush his or her dialogue entries this value may be 
adjusted to accommodate them and later re-edited into the proper lip-synced 
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position. It also maintains the proper Countdown, Beep and visual Wipes posi-
tions in relation to the actual text.

Punch Out Post Roll This setting defines the offset of the actual Record Off command in relation to the 
Loop Out position. This enables the user to record a little further into the Post Roll 
than the actual Loop Out position to allow for a margin of trailing breathing, 
reverberation or dialogue at the end of takes. This function could be adjusted to 
accommodate the acoustic reverberation times of a particular studio without hav-
ing to manually extend each Loop Out point one by one and while maintaining 
coherent visual Wipe timings.

Countdowns
Number of This parameter defines the number of Countdown Events preceding the Loop In 

position. Each Countdown Event results in the display of a countdown wipe in the 
VCube and a GPO tally that may be used for external Countdown display. The 
maximum number of countdown events is 5.

Length This parameter defines the length of each Countdown Event in:
Hours:Minutes:Seconds:Milliseconds.

Style This parameter offers a choice of the various different types of the visual Count-
down Wipes generated in the VCube.

Opacity This parameter defines the transparency of the colored elements of the Count-
down Wipes generated in the VCube.

Pre Roll ***Under Construction***

Beeps
Number of This parameter defines the number of audio Beep pulse events preceding the 

Loop In Position. Each audio Beep pulse event results in the generation of a beep 
by Pyramix which is played out through the ADR Monitor grid. A GPO tally may 
also be sent out through an attached USB GPIO interface that may be used for 
external countdown display flashes. The maximum number of audio beep events 
is 5.

Gap This parameter defines the timing of each Beep before the Loop In point in 
Hours:Minutes:Seconds:Milliseconds. This parameter is comparable to the 
Countdown Length setting and should be identical in value if the user wants the 
audio beeps and wipes to be in sync.

Length This parameter defines the length of each audio Beep in 
Hours:Minutes:Seconds:Frames. Typically, a value of 2 frames makes for a com-
fortable audio Beep, longer Beeps may perturb the listener's perception of the 
countdown rhythm.

Pre Roll ***Under Construction***

Sound File This setting opens a Windows OPEN browser box enabling the user to choose the 
default .wav sound file for the first series of Beeps.

Last Sound File This setting opens a Windows OPEN browser box enabling the user to choose the 
default .wav sound file for the last Beep before the Loop In position.

Level This setting enables the user to boost or attenuate the gain level of the sound file 
of the first series of Beeps.

Last Level This setting enables the user to boost or attenuate the gain level of the sound file 
of the last Beep before the Loop In point.

Wipes
Enabled Activates the generation of Record Wipes in the VCube that visually indicate the 

remaining length of a Loop Take pass.

Style Offers a choice of different appearances for the visual Record Wipe, generated in 
the VCube.

Opacity Defines the transparency of the colored elements of the visual Record Wipe gen-
erated in the VCube.

Pre/Post Roll ***Under Construction***
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ADR Menu

The ADR option adds a new menu and a new Tab Window to Pyramix.

ADR menu
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Commands

Commands

Import LoopsOpens the Import Loop List window

Export Loops SheetNot yet implemented

Consolidate Loops & TakesCreates an Edit Track Group per production Character with all 
selected take clips in the Timeline for playback through their respective mixer outputs

Select Previous LoopNavigates the Selection Cursor to previous loop in the ADR/Loops page 
without changing the Active Loop status

Select Next LoopNavigates the Selection Cursor to next loop in the ADR/Loops page without 
changing the Active Loop status

Select LoopOpens the Select Loop dialog box. This allows the number of the loop you wish to 
select to be directly entered by typing the number on the numerical keypad and pressing 
Enter/OK or Esc/Cancel.

New Loop InCreates a new ADR loop according to the conditions on the Settings/ Loops Edit-
ing page. In Point is automatically assigned to the current cursor position in the Timeline.

Delete LoopDeletes the selected loop from the ADR/Loops list.

No Icon yet  Renumber all LoopsAutomatically renumbers the ADR/Loop/ ID column with numbers from 
1 upwards, replacing any former characters or number distinctions from the top of the column 
to the bottom. Users may sort columns by ID, In, Out, Duration, Scene, Character, Type, Date, 
Status or Comments but not Takes or Selected. The current column selected for sort order is 
indicated by a *

Note: This is normally not a function you would wish to invoke during a recording ses-
sion. It is principally provided for use when preparing loops.

Activate LoopCreates a new Character Track in the Timeline and recalls any past Loop Takes 
of the selected Loop in the current character's Track Group. All past takes are automatically 
Track Muted and the current track is placed in Input Monitor mode and is ready for automatic 
record Punch-in or Rehearsal. If the VCube is open and a video file is properly referenced for 
the current loop it is automatically loaded and placed in the VCube's Timeline as well as the 
creation of a higher priority video track containing the sub-layers with the automatically gener-
ated countdown and wipe overlays. The countdown and wipe overlays are automatically 
muted and un-muted for Loop Recording and Rehearsal. They are muted for the Review 
mode along with the beeps and GPIO events.
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Deactivate LoopDeactivates the selected Loop in the ADR/Loops page and removes the 
selected Character's Track Group and its associated Take Tracks from the Timeline.

Deactivate all LoopsDeactivates all active Loops in the ADR/Loops page and removes all of 
their respective Character Track Groups and their associated Take Tracks from the Timeline.

Select/Activate Previous Loop  Simultaneously deactivates the current Active Loop on the 
ADR/Loops page while it selects and activates the previous (higher in the column) Loop.

Select/Activate Next LoopSimultaneously deactivates the current active Loop on the ADR/
Loops page while it selects and activates the next (lower in the column) Loop.

Select/Activate LoopOpens the Select/Activate Loop dialog box. This allows the number of 
the Loop you wish to Select and Activate to be directly entered by typing the number on the 
numerical keypad and pressing Enter/OK or Esc/Cancel. Activating a new loop with this dia-
log box deactivates ALL other active Loops in the ADR/Loops page.

Set Loop InSets the Loop In point at the cursor position of the currently selected Loop. If the 
Create New Loop option is set to yes on the ADR/Loops page the Set Loop In function also 
automatically creates a new Loop.

Set Loop OutSets the Loop Out point at the cursor position of the currently selected Loop. If 
the Create New Loop option is set to yes on the ADR/Loops page the Set Loop Out function 
also automatically creates a new loop with the in point of the currently selected loop. Note: If 
the user tries to set the Out Point before the currently selected loop’s In point no new Loop is 
created. The user should use the New Loop In or Set Loop In functions instead.

Select Previous TakeScrolls up through the currently active Loop takes designating the 
Selected Take (good take) that will be used in the Consolidated Track functions. If no Loop is 
actively selected in the ADR/Loops page then New Take switching is inactive.

Select Next TakeScrolls down through the currently Active Loop takes designating the 
Selected Take (good take) that will be used in the Consolidated Track functions. If no Loop is 
actively selected in the ADR/Loops page then New Take switching is inactive.

Undo Last TakeErases the last Loop take pass in the active Character Loop and removes its 
corresponding Clip and associated Track from the Character Group in the Timeline. This func-
tion works in any active Character Loop to reduce the number of associated takes and tracks 
at any point in time during an ADR session, unlike a classic Undo function.

Consolidate TakeConsolidates the Selected Take of the Active Character loop by creating a 
permanent Track after the Guide Tracks and before the Character Loop Groups and placing 
the Selected Take on that track for review. The newly created track is routed to same mixer 
strip as the Character Loop tracks but is not muted.

Goto Play PreRollLocates the cursor to the PreRoll position of the first of any Active Loops. 
Note: This function does not locate the cursor during Playback or if no Loops are Active.
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Goto First Count-downLocates the cursor to the First Count-down position of the Active Loop.

Goto First BeepLocates the cursor to the First countdown Beep position of the Active Loop.

Goto Loop InLocates the cursor to the active Loop In Marker position for quick verification of 
the punch-in point

Goto loop OutLocates the cursor to the active Loop Out Marker position for quick verification 
of the punch-out point

Goto Play PostRollLocates the cursor to the end of the active Loop's PostRoll position to 
quickly verify sufficient PostRoll for review playback passes.

RehearsePlaces the Pyramix in a simulated Loop Record pass mode. This enables you to 
Rehearse the Active Loop without actually recording a Take. It fully automates the horizontal 
Track Zoom, Guide Track Mutes, Track Input modes, Wipes, GPOs, Beeps and audio Guide 
Tracks according to their associated Actors' monitoring Output Channels.

RecordRecords the current Active Loops with all automatic monitoring and visual cues active 
according to the desired options in the ADR/Settings page. Each successive record pass cre-
ates a new Character Loop Track and automatically mutes the previous Loop Tracks to avoid 
Loop summing during playback.

ReviewPlays back the Pyramix from the first Active Loop's PreRoll position all the way 
through to the last Active Loop's PostRoll position unmuting any tracks containing a Selected 
Take. This mode does not display the Wipes, activate GPO events, or play back the Beeps so 
as not to distract from evaluation of the recorded materiel.

Cycle RehearsePlaces the Pyramix in Rehearse mode with cycled playback between the first 
PreRoll in position and the last PostRoll out position continuously until manually stopped.

Cycle RecordPlaces the Pyramix in Record mode with cycled punch-in and punch-out record-
ing and successive Track Loop creation between the first PreRoll In position and the last Pos-
tRoll out position continuously until manually stopped.

Cycle ReviewPlaces the Pyramix in Review mode Playing back between the first PreRoll In 
position and the last PostRoll out position continuously until manually stopped.

Instant RehearseForgoes the PreRoll position of the first Active Loop and enables you to 
make a Rehearse pass from anywhere in the Timeline preceding the last PostRoll position. 
Note: Unlike a standard manual Play command, in Instant Rehearse mode all automatic ADR 
functions are active and playback stops at the end of the PostRoll position. If no loop is active 
Instant Rehearse does not initiate playback.

Instant RecordForgoes the PreRoll position of the first active loop and enables you to make a 
record pass from anywhere in the Timeline preceding the last PostRoll position. Note: Unlike a 
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standard manual Record command, in Instant Record mode all automatic ADR functions are 
active and playback stops at the end of the PostRoll position. If no loop is active Instant 
Record does not initiate a record pass.

Instant ReviewForgoes the PreRoll position of the first active loop and allows you to Review 
the ADR project from anywhere in the Timeline preceding the last PostRoll position. Note: 
Unlike the Rehearse command, in Instant Review mode all automatic ADR functions are inac-
tive and playback stops at the end of the postroll position. If no Loop is active Instant Review 
does not initiate playback.

StopStops Pyramix in any playback or record mode keeping any recorded Loops in the ADR/
Loops page and in the Timeline.

AbortStops Pyramix in any playback or record mode discarding any recorded Loops created 
in the current record pass in the ADR/Loops page and in the Timeline but preserves the Media 
Files in the project's record media folder.
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Settings

The precise settings in the applications may vary according to the user’s specific circumstances.

The settings advice that follows applies to a PyraCube I.e. a single PC running VCube in SE mode with Pyramix and 
Virtual Transport.

Pyramix
Check Settings > All Settings > Remote Control > Virtual Transport

They should look like this:

I.e. the following items should be checked:

Enable Virtual Transport Communication

Automatically Set as Clock Master

Automatically Set as TimeCode Master

Chase Mode: Soft

Force TimeCode Source to External / Virtual Transport

Clients State Saving: Save Clients on Local Server

Pyramix Settings > Remote Control > Virtual Transport
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Editing: Synchronize Virtual Transport with Editing Moves

VCube Options
The final setting on the page determines which VCube will be used with Pyramix ADR.

 Associated VCube network name (blank for local computer)

Please enter the network name of the VCube workstation that you intend to use with Pyramix ADR. 

Leave the field blank or with a period . if you wish to use the local machine.  

Record Path
Set the Loop Record Path in the Settings > All Settings > Project > Record : General page

Use the Project Media Folder Drop-down list or the ... Browser button and set an appropriate Record Path.

VCube
The only setting (from a fresh install) that requires checking is Follow VT which can be found in Settings > For-
mats & Sync Settings : Synchronization - TimeCode (from and to External) :

VCube   Settings > Formats & Sync Page
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Pyramix and VCube on One Screen
If you are running on a single screen you may find it helpful to set VCube to TopMost Only When Floating and 
Display Taskbar in the Settings > User-Interface window. With these settings in place you can then use F4 to 
toggle between Normal and Floating modes and F3 to toggle between either and Full Screen. Alt + Tab is used to 
toggle between the applications. 

Virtual Transport
The Virtual Transport Clients Frame should look like this:

The points to note are that Pyramix is set to Clock Master and TC Master, VT is set to Chase and both are set to 
Lock.

Virtual Transport Clients Frame
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GPO Commands

Any or all of the following commands may be assigned to General Purpose Outputs (GPOs) for activation of exter-
nal switching destinations in Settings > All Settings > Project > Controller Mapping (Choose the GPIO control-
ler you have installed and click on Properties to open the Mapping dialog.)

Beep 4 through 0 Sends a tally signal on a separate output for the duration of each audio beep 
countdown preceding the Punch-in point in Record and Rehearse modes. This 
type of tally is typically used as a switch to momentarily light-up a series of num-
bered flashes to visually indicate the countdown to recording in a silent studio.

Beeps Sends a tally signal on a single output for each audio beep countdown proceeding 
the punch-in point in Record and Rehearse modes. This type of tally is typically 
used as a switch to momentarily light-up a flash to visually indicate the countdown 
to recording in a silent studio.

CountDown 4 through 0 Sends a tally signal on a separate output from one cycle before the first count-
down wipe in the Vcube to the end of wipe "2". The countdown tallies are not 
pulsed like the beep tallies but remain on for the entire duration of each count-
down wipe. Countdown tallies are active in the Record and Rehearse modes. This 
type of tally is typically used as a switch to light-up a series of numbered displays 
or a LED counter to visually indicate the countdown to recording in a silent studio.

Play PostRoll Sends a continuous tally during the PostRoll period of the last active loop in 
Record and Rehearse modes. This type of tally is typically used as a switch to 
light-up a display to visually indicate the Playback Status of the ADR system in the 
PostRoll zone.

Play Preroll Sends a continuous tally during the PreRoll period of the first active loop in 
Record and Rehearse modes. This type of tally is typically used as a switch to 
light-up a display to visually indicate the Playback Status of the ADR system in the 
PreRoll zone.

Punch In Sends a pulsed tally at the first Loop Record Punch-In point in Record and 
Rehearse modes. This type of tally is typically used as a trigger to a secondary 
recording machine to punch-in recording.

Punch Out Sends a pulsed tally at the last Loop Record Punch-Out point in Record and 
Rehearse modes. This type of tally is typically used as a trigger to a secondary 
recording machine to Punch-out of recording.

Punching Sends a continuous tally during the entire Loop Record pass from the first Punch-
in point to the last Punch-out point whether or not actually Recording or in 
Rehearse and Review modes. This type of tally is typically used as a switch to 
light-up a display to visually indicate the Record/Punch-In area of the currently 
active Loop during a Loop pass.

Recording Sends a continuous ON AIR style tally during the entire length of a Record pass 
including Preroll and Postroll periods indicating that recording is taking place in 
Loop Record mode. This type of tally is typically used as a switch to light-up a dis-
play to visually indicate the Recording Status of the ADR system during the current 
loop pass.

Rehearsing Sends a continuous ON AIR style tally during the entire length of a Rehearse pass 
including Preroll and Postroll periods indicating that rehearsal is taking place in 
Loop Rehearse mode. This type of tally is typically used as a switch to light-up a 
display to visually indicate the Rehearsing mode status of the ADR system during 
the current loop pass.

Reviewing Sends a continuous ON AIR style tally during the entire length of a Review pass 
including Preroll and Postroll periods indicating that a review is taking place in 
Loop Review mode. This type of tally is typically used as a switch to light-up a dis-
play to visually indicate the Reviewing mode status of the ADR system during the 
current loop pass.
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Using ADR With a Backup Machine 
The diagram below demonstrates one possible set-up for concurrent automatic back-up of ADR sessions.

Although a Pro Tools is illustrated, this arrangement will work with any suitable machine equipped with the Sony 
9-pin (P2) protocol. 

Note: The above diagram shows control cabling only Audio and Video cabling is ommit-
ted.

Note: Pyramix and VCube may co-exist in one computer.

LTC (optional)

Loop Sync

Primary port

Host serial

Ethernet

Video Ref.

USB

RS 422 RS 422
USB

i.e. Keyspan

To Machine 
(Master)

Pyramix up to v.6.1

PT HD
Tested with v.7.4

HD Core

HD Core

VCube v.2.0

Backup - Typical Control Cabling setup
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Pyramix Setup:

Add a Machine
First add one or more Sony 9-pin (P2) protocol machines in the All Settings > Remote Control > Machines sec-
tion of Pyramix. Please consult the Pyramix User Manual for full details of the following machine settings : 

Note: If machine is a Pro Tools, check Filter the Standby bit as in the above screenshot. 

Backup - Pyramix :  Sony 9-Pin Protocol Configuration dialog
ADR Guide : Using ADR With a Backup Machine Page 33



Transport Window
Once these settings are made check that the Machine is present and online in the Transport Pyramix window.

There are two possibilities for chasing. Either the slave machine chases an incoming TimeCode (LTC) coming from 
the Pyramix or the slave machine Chase mode is activated in the Transport window. We recommend the second 
method; the first method may be used if it improves the lock time. 

Note: Note: Up to 96 tracks may be addressed even if the machine control window 
shows only 12 track arm status buttons.

Backup - Pyramix :  Transport window
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ADR Machine Assignment
Once the slave machine is correctly installed the Character section of the ADR Production tab page will show the 
Backup Machine to assign as well as the Backup Track Arm # assigned to each Character :

Note: The syntax used to assign multiple Track Arm #s is a sequence of target track 
numbers separated by  commas. I.e 1, 2, 24, 25

Backup - Pyramix : ADR Tab Window Production Tab
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Punch In Delay Compensation
Some machines exhibit 1 or more frames delay after receiving a Punch command before entering Record and or 
returning to Replay.

The Backup Punch In Pre Roll and Backup Punch Out Post Roll settings, available in the ADR Settings Tab, allow 
this delay to be compensated for. 

Backup - Pyramix : ADR Tab Window Settings Tab
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Video Reference
In order to maintain sample accuracy in the entire setup, Pyramix, VCube, and the slave Machine must be refer-
enced to a common Video Ref. signal. The frame rate must also be the same throughout the system :  In Pyramix 

go to All Settings > Hardware > Formats & Sync and check the different options. In the above example the Video 
Ref. is SD - NTSC and the frame rate is 29.97 non drop.

Backup - Pyramix : All Settings > Hardware > Formats and Sync
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Pro Tools Setup: 

Machine Control 

Enable the 9-Pin Remote (Deck Emulation) from Setup > Peripherals : Machine Control.

The Chase LTC option can also be checked if the Pyramix chase synchronizer is not quick enough to lock. 

Note: The lock time in Chase depends directly on the numbers of tracks present in the 
timeline.

Backup - Pro Tools :  Setup > Peripherals > Machine Control Tab
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Preferences 

In Setup > Preferences… > Operation, check Audio Track RecordLock and Transport RecordLock as above.

Backup - Pro Tools : Setup > Preferences : Operation Tab
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SYNC Peripheral 

Enable the SYNC Peripheral from Setup > Peripherals : Synchronization. If these options are not available, your 
Pro Tools system is probably not connected to the SYNC device. The SYNC device is necessary for this Setup.

Backup - Pro Tools : Setup > Peripherals : Synchronization Tab
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Session Settings 

When a Session is created, set the Session option Clock Source, Clock Reference, Video Ref Format and the 
Time Code Rate as above (for an NTSC setup).

Backup - Pro Tools : Session Settings
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Options Menu 

In the Options menu, check that TrackPunch and Transport Online are enabled.

Backup - Pro Tools : Options Menu
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